Qiscus Omnichannel dashboard page cannot be opened
Incident Report for Qiscus
Postmortem

Root Cause Analysis Report - Trouble Authentication Service

On Monday, 16 October 2023, between 4:54 PM and 6:35 PM UTC+7, clients using the Qiscus Omnichannel Dashboard experienced an inability to access the platform. Despite the API and Webhook services operating normally, authentication service issues were identified as the cause of the disruption. The issue was resolved, and preventive measures were implemented to avoid similar incidents in the future.

Timeline:

  1. Event Start (16 October 2023, 4:54 PM UTC+7)
  2. Clients reported inability to access the Qiscus Omnichannel Dashboard, while API and Webhook services remained unaffected.
  3. Identification of Abnormal Authentication Service (16 October 2023, 4:56 PM UTC+7)
  4. The tech team discovered irregularities in the authentication service, pinpointing it as the root cause.
  5. Resolution (16 October 2023, 6:35 PM UTC+7)
  6. The tech team resolved the issue with the authentication service, restoring system functionality.

Root Cause:
The disruption stemmed from abnormalities in the authentication service, preventing users from accessing the Qiscus Omnichannel Dashboard. This critical component failed to function correctly, impacting the platform's usability.

Mitigation and Preventive Actions:
To prevent future occurrences, the following measures were taken:

  • Immediate resolution of the authentication service issue.
  • Implementation of enhanced monitoring and log analysis to detect similar anomalies promptly.
  • Continuous monitoring to ensure the system's stability.
  • Commitment to ongoing improvements and enhancements to the service based on lessons learned from this incident.

Conclusion:
The incident shed light on the importance of a robust and reliable authentication service. The team's prompt identification and resolution of the root cause, along with the implementation of preventive measures, demonstrate a commitment to maintaining the stability and functionality of the Qiscus Omnichannel Dashboard.

Posted Oct 17, 2023 - 16:11 WIB

Resolved
This issue has been resolved and users should now be able to open Qiscus Omnichannel dashboard, load and send messages. We're sorry for the disruption we brought to your day.
Posted Oct 16, 2023 - 18:35 WIB
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2023 - 18:30 WIB
Investigating
Some users are encountering issues loading Qiscus Omnichannel dashboard. We are currently investigating this issue.
Posted Oct 16, 2023 - 16:54 WIB
This incident affected: Omnichannel Backend.