Third-Party Service Disruption - WhatsApp Room Duplication

Incident Report for Qiscus

Resolved

Meta has deployed a fix and the issue is resolved. No further duplicate rooms are being created.
Posted Apr 09, 2026 - 13:07 WIB

Identified

The root cause has been confirmed on Meta's side. Their Cloud API is intermittently sending phone numbers with a duplicated country code, causing new rooms to be created for existing customers.
Posted Apr 08, 2026 - 16:18 WIB

Investigating

We identified an issue where some WhatsApp rooms are being duplicated due to a phone number format inconsistency from Meta's WhatsApp Cloud API. Our team has escalated this to Meta support.
Posted Apr 08, 2026 - 15:57 WIB
This incident affected: Omnichannel Backend.