Memory Issue in Robolabs
Incident Report for Qiscus
Postmortem

Root Cause Analysis Report - Memory Issue in Robolabs
We have detected an issue with our Robolabs service, which resulted in chatbot being unable to auto resolve room in Omnichannel Chat from November 3, 2023 12:01 AM to November 3, 12:34 PM UTC+7. The issue has been resolved, and preventive actions have been implemented to avoid similar incidents in the future.

Timeline:

  1. We received an alert regarding our internal system, and then we conducted an investigation (November 3, 2023 12:01 AM UTC +7)
  2. The tech team identified the issue and began working on fixing it (November 3, 2023 9:30 AM UTC +7)
  3. The tech team resolved the issue, restoring system functionality (November 3, 2023 12:34 PM UTC +7)

Root Cause:
The disruption was caused by a spike in usage so that the temporary storage media failed to carry out the storage process.

Mitigation and Preventive Actions:
To prevent future occurrences, the following measures were taken:

  • Tweaked configurations in temporary storage
  • Continuous monitoring to ensure the system’s stability.
Posted Nov 09, 2023 - 15:41 WIB

Resolved
Chatbot being unable to auto resolve room in Omnichannel Chat
Posted Nov 03, 2023 - 00:01 WIB