Uploader Service Issue
Incident Report for Qiscus
Postmortem

Root Cause Analysis Report - Uploader Service

We have detected an issue with our uploader service, which resulted in agents, supervisors, and admin being unable to upload images and files through the dashboard or API media from 5:31 PM UTC+7 to 6:44 PM UTC+7. The issue has been resolved, and preventive actions have been implemented to avoid similar incidents in the future.
Timeline:

  1. We received an alert regarding our internal uploader service, and then we conducted an investigation (5:31 PM UTC +7)
  2. The tech team identified the issue and began working on fixing it (6:35 PM UTC +7)
  3. The tech team resolved the issue, restoring system functionality (6:44 PM UTC +7)


Root Cause:
The issue occurred in our uploader service, the caching function was disrupted, causing users (agents, supervisors, and administrators) to be unable to upload images and files in the Omnichannel Dashboard or via the API media.

Mitigation and Preventive Actions:
To prevent future occurrences, the following measures were taken:

  • Improve caching function
  • Continuous monitoring to ensure the system’s stability.
Posted Nov 01, 2023 - 09:22 WIB

Resolved
We have detected an issue with our uploader service, which resulted in agents, supervisors, and admin being unable to upload images and files through the dashboard or API media from 5:31 PM UTC+7 to 6:44 PM UTC+7
Posted Oct 31, 2023 - 17:30 WIB