Qiscus Omnichannel dashboard page cannot login

Incident Report for Qiscus

Resolved

The issue has been addressed and services are functioning as expected. We are actively monitoring to ensure continued stability.
We appreciate your patience and understanding.
Posted Aug 12, 2025 - 11:27 WIB

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 11:15 WIB

Investigating

Some users are encountering issues loading Qiscus Omnichannel dashboard. We are currently investigating this issue.
We apologize for any inconvenience this may cause and thank you for your patience while we work on a solution.
Posted Aug 12, 2025 - 10:53 WIB
This incident affected: Omnichannel Backend.