Qiscus Omnichannel Service Disruption

Incident Report for Qiscus

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 03:00 WIB

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 02:30 WIB

Investigating

We are currently experiencing performance issues that are disrupting access to download attachment files on the Qiscus Omnichannel service.

This issue is related to the Meta service.

We apologize for the inconvenience.
Posted Jan 20, 2026 - 20:31 WIB
This incident affected: Omnichannel Backend.