Degraded Performance on Room Chat

Incident Report for Qiscus

Resolved

This incident has been resolved. All services are operating normally.
Posted Apr 21, 2026 - 11:36 WIB

Monitoring

The configuration has been reverted and services are recovering. We are monitoring to ensure stability across all components.
Posted Apr 21, 2026 - 11:13 WIB

Identified

The root cause has been identified as a database configuration change that caused increased latency on read operations. A rollback is currently in progress.
Posted Apr 21, 2026 - 10:48 WIB

Investigating

We are aware that some users are experiencing issues with loading room chat and accessing messages. Our engineering team is currently investigating.
Posted Apr 21, 2026 - 10:07 WIB
This incident affected: Omnichannel Backend.