Slow Loading Conversation
Incident Report for Qiscus
Postmortem

Root Cause Analysis Report - Issues with Loading Conversations for Agents

On the date of the incident, we experienced intermittent issues with the loading of conversations. These issues were primarily reported by agents, although supervisors also experienced some disruptions.

The issue had two peak periods. The first was from 09:50 to 11:09 and the second from 15:50 to 16:04. Outside of these periods, a minority of users experienced minor issues. The issue was fully resolved at around 16:31.

Upon investigation, we determined the root cause was a problem with our memory database architecture, which intermittently increased server load, causing these loading issues.

Once identified, the technical team was able to fix the issue in the memory database architecture. This fix stabilized the server load, restoring normal conversation loading functionality by 16:31.

To prevent such incidents in the future, we plan to:

  1. Implement stress testing of our memory database architecture to predict potential server load issues.
  2. Enhance system monitoring for improved early detection of similar problems.
  3. Regularly update our incident response protocols for faster resolution.

We have learned from this incident and are committed to improving our services based on these insights. We apologize for any inconvenience caused and appreciate everyone's patience during this incident.

Posted Jul 21, 2023 - 18:01 WIB

Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 16:31 WIB
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2023 - 10:33 WIB
Investigating
We are currently investigating this issue.
Posted Jul 21, 2023 - 09:56 WIB
This incident affected: Omnichannel Backend.