Slow Loading Omnichannel Dashboard
Incident Report for Qiscus
Resolved
This incident has been resolved.
Posted Jun 19, 2023 - 11:33 WIB
Investigating
We are currently investigating this issue.
Posted Jun 19, 2023 - 11:04 WIB
This incident affected: Omnichannel Backend.