Qiscus Omnichannel Service Disruption

Incident Report for Qiscus

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 22:22 WIB

Investigating

We are currently experiencing performance issues that are causing access to the Qiscus Omnichannel service to be slower than usual. This relates to https://www.cloudflarestatus.com/.

We apologize for the inconvenience.
Posted Nov 18, 2025 - 19:15 WIB
This incident affected: Omnichannel Backend.