Slow Loading Omnichannel Dashboard
Incident Report for Qiscus
Postmortem

Root Cause Analysis Report - Search Service

We have detected an issue with our search service, which resulted in agents, supervisors, and administrators being unable to load data for the unserved tab, resolved tab, and ongoing tab on the Inbox page. The issue occurred from 13:20 PM to 13:43 PM UTC+7. It has since been resolved, and preventive actions have been implemented to avoid similar incidents in the future.

Timeline:

  1. We received an alert regarding search service, and then we conducted an investigation (13:20 PM UTC +7)
  2. The tech team identified the issue and began working on fixing it (13:22 PM UTC +7)
  3. The tech team resolved the issue, restoring system functionality (13:43 PM UTC +7)


Root Cause:
The issue occurred in our search service, the search service function was disrupted, causing users (agents, supervisors, and administrators) to be unable to load data for the unserved tab, resolved tab, and ongoing tab on the Inbox page.

Mitigation and Preventive Actions:
To prevent future occurrences, the following measures were taken:

  • Improve storing data mechanism
Posted Jan 10, 2024 - 10:35 WIB

Resolved
This incident has been resolved.
Posted Dec 29, 2023 - 13:43 WIB
Investigating
We have detected an issue with our search service, which resulted in agents, supervisors, and administrators being unable to load data for the unserved tab, resolved tab, and ongoing tab on the Inbox page.
Posted Dec 29, 2023 - 13:20 WIB
This incident affected: Omnichannel Backend.